AP EIC

transforming careers...
Gen Al & Agentic Al
DATA SCIENCE

Data Analytics | Machine Learning | Artificial Intelligence | NLP | Python | R

GENERATIVE AI (Gen AI)
» Gen Al Basics & Use-cases:
o Generative vs. Discriminative
o Text/code/image/audio generation
o Common pitfalls (hallucination, bias)
» Large Language Models (LLMs):
o LLM Assistants (ChatGPT, Gemini, Perplexity, Copilot)
o Tokenization & embeddings
o Attention and context window, System/user/tool messages
» Prompt Engineering:
o Role/goal/context framing
o Zero/few-shot, CoT, self-consistency
o Prompt testing templates
> Retrieval-Augmented Generation (RAG):
o Chunking & indexing
o Vector stores and hybrid search
o Grounding with citations
» Evaluation & Guardrails:
o LLM-as-judge vs. metrics (BLEU/ROUGE)
o Toxicity/PII filters, Factuality & hallucination checks
» Fine-tuning & Adaptation:
o LORA/QLORA basics, Instruction-tuning vs. RAG
o Data curation & alignment
» Multimodal GenAI:
o Vision-language models
o Doc Q&A and layout parsing
o ASR/TTS pipelines
» GenAlI MLOps:
o Prompt/version tracking
o Offline/online eval & observability
o Caching and cost controls
» Deployment Patterns:
o Batch vs. streaming tokens
o Latency/SLO tuning, CPU/GPU selection
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AGENTIC AI (AGENTS)
» Agentic Al Foundations:
o Planner-executor loop, Tools, memory, reflection
o Multi-turn objectives
» Tool Use & Orchestration:
o Function calling schemas
o Retries/fallbacks/timeouts, Parallel tool execution
» Planning Strategies:
o ReAct and Tree-of-Thought
o Task decomposition, Checkpoints & sub-goals
» Memory for Agents:
o Short-term scratchpad, Long-term vector memory
o Episodic vs. semantic retrieval
» Multi-Agent Systems:
o Role design (researcher/coder/critic)
o Communication protocols, Handoff patterns
» Agent Workflows/Frameworks:
o Graph/state-machine agents, DAG/event-driven flows
o Overview of common OSS stacks
» Safety for Agents:
o Tool allow/deny lists, Rate/budget limits
o Human-in-the-loop (HITL)
» Agents + RAG:
o Tool-augmented retrieval
o Query rewriting, Citation enforcement
> Evaluation of Agents:
o Task success & robustness
o Cost/time to completion, Reproducibility & audits
» Productionizing Agents:
o Secrets, key management
o Telemetry & logs
o Fail-safes, Rollback & Kill-switch

INTRODUCTION TO DATA SCIENCE

What is a Data Science?

Who is a Data Scientist?

Who can become a Data Scientist?

What is an Artificial Intelligence?

What is a Machine Learning?

What is a Deep Learning?

Artificial Intelligence Vs Machine Learning Vs Deep Learning
Real Time Process of Data Science

Data Science Real Time Applications
Technologies used in Data Science
Prerequisites Knowledge to Learn Data Science

VVVVVVYVVYVY
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INTRODUCTION TO MACHINE LEARINING

YVVYVY

What is a Machine Learning?

Machine Learning Vs Statistics

Traditional Programming Vs Machine Learning
How Machine Will Learn like Human Learning
Machine Learning Engineer Responsibilities
Types of Machine Learning

e Supervised learning

e Un-Supervised learning

e Reinforcement Learning

CORE PYTHON PROGRAMMING

VVVVYVYYYVYYYVY

VVVVVVVVYVVVYVYY

YV VYV

PYTHON Programming Introduction
History of Python
Python is Derived from?
Python Features & Applications
Why Python is Becoming Popular Now a Day?
Existing Programming Vs Python Programming
Writing Programs in Python
Top Companies Using Python
Python Programming Modes
o Interactive Mode Programming
o Scripting Mode Programming
Flavors in Python, Python Versions
Download & Install the Python in Windows & Linux
How to set Python Environment in the System?
Anaconda - Data Science Distributor
Downloading and Installing Anaconda, Jupyter Notebook & Spyder
Python IDE - Jupyter Notebook Environment
Python IDE - Spyder Environment
Python Identifiers(Literals), Reserved Keywords
Variables, Comments, Lines and Indentations, Quotations
Assigning Values to Variables
Data Types in Python, Mutable Vs Immutable
Fundamental Data Types: int, float, complex, bool, str
Number Data Types: Decimal, Binary, Octal, Hexa Decimal & Number
Conversions
Inbuilt Functions in Python
Data Type Conversions
Priorities of Data Types in Python
Python Operators
o Arithmetic, Comparison (Relational), Assignment, Logical,
Bitwise, Membership & Identity Operators
Slicing & Indexing
o Forward Direction Slicing with +ve Step
o Backward Direction Slicing with -ve Step
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» Decision Making Statements

o If, if-else & elif Statements
» Looping Statements
Why we use Loops in python?
Advantages of Loops
for Loop & Nested for Loop
Using else Statement with for Loop
while Loop & Infinite while Loop

o Using else with Python while Loop
» Conditional Statements

o Break, Continue, Pass Statements

0O O O O O

ADVANCED PYTHON PROGRAMMING
» Advanced Data Types: List, Tuple, Set, Frozenset, Dictionary, Range,
Bytes & Bytearray, None
> List Data Structure
List indexing and splitting
Updating List values
List Operations
Iterating a List
Adding Elements to the List
Removing Elements from the List
o List Built-in Functions & Methods
» Tuple Data Structure
o Tuple Indexing and Splitting
Tuple Operations
Tuple Inbuilt Functions
Where use Tuple
List Vs Tuple
Nesting List and Tuple
» Set Data Structure
Creating a Set
Set Operations
Adding Items to the Set
Removing Items from the Set
Difference Between discard() and remove()
Union of Two Sets
Intersection of Two Sets
Difference of Two Sets
o Set Comparisons
» Frozenset Data Structure
» Dictionary Data Structure
o Creating & Accessing the Dictionary Values
o Updating Dictionary Values
o Deleting Elements Using del Keyword
o Iterating Dictionary

o O O O O O

O O O O O

O O O O 0 O O O
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o Properties of Dictionary Keys
o Built-in Dictionary Functions
o Built-in Dictionary Methods
List Vs Tuple Vs Set Vs Frozenset Vs Dict
Range, Bytes, Bytearray & None
Python Functions
o Advantage of Functions in Python
Creating a Function
Function Calling
Parameters in Function
Call by Reference in Python
Types of Arguments
» Required, Keyword, Default, Variable-Length Arguments
Scope of Variables
Python Built-in & Lambda Functions
String with Functions
o Strings Indexing and Splitting
o String Operators
o Python Formatting Operator
o Built-in String Functions
» Python File Handling
o Opening a File, Reading the File & Read Lines of the File
Looping through the File
Writing the File & Creating a New File
Using with Statement with Files
File Pointer Positions
Modifying File Pointer Position
Renaming the File & Removing the File
Writing Python Output to the Files
o File Related Methods
» Python Exceptions
o Common Exceptions
Problem without Handling Exceptions
except Statement with no Exception
Declaring Multiple Exceptions
Finally Block
o Raising & Custom Exceptions
» Python Packages
o Python Libraries
o Python Modules
= Collection, Math, OS, Random, Statistics, Sys Modules
» Date & Time Module
o Loading the Module in our Python Code
» import Statement
= from-import Statement
o Renaming a Module

YV V
O 0O 0 0 O

Y V V

o O O O 0O O O
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Regular Expressions
Command Line Arguments
Object Oriented Programming (OOPs)
o Object-oriented vs Procedure-oriented Programming languages
o Object, Class, Method, Inheritance, Polymorphism, Data
Abstraction & Encapsulation
» Python Class and Objects
o Creating Classes in Python
o Creating an Instance of the Class
» Python Constructor
o Creating the Constructor in Python
o Parameterized & Non-Parameterized Constructors
o In-built Class Functions & Attributes
» Python Inheritance
o Python Multi-Level & Multiple Inheritance
o Method Overriding
o Data Abstraction in Python
» Graphical User Interface (GUI) Programming
» Python TKinter
o Tkinter Geometry
» pack(), grid(), place() Methods
o Tkinter Widgets

Y V V

DATA ANALYSIS WITH PYTHON NUMPY
» NumPy Introduction
o What is NumPy
o The Need of NumPy
» NumPy Environment Setup
» N-Dimensional Array (Ndarray)
o Creating a Ndarray Object
Finding the Dimensions of the Array
Finding the Size of Each Array Element
Finding the Data Type of Each Array Item
Finding the Shape and Size of the Array
Reshaping the Array Objects
Slicing in the Array
Finding the Maximum, Minimum, and Sum of the Array Elements
NumPy Array Axis
Finding Square Root and Standard Deviation
Arithmetic Operations on the Array
o Array Concatenation
» NumPy Datatypes
o NumPy dtype
o Creating a Structured Data Type
» Numpy Array Creation
o Numpy.empty

0 O O O o0 O O O 0 O
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o Numpy.Zeros
o NumPy.ones
» Numpy Array from Existing Data
o Numpy.asarray
» Numpy Arrays within the Numerical Range
o Numpy.arrange
o NumPy.linspace
o Numpy.logspace
» NumPy Broadcasting
o Broadcasting Rules
» NumPy Array Iteration
o Order of Iteration
» F-Style Order
= C-Style Order
o Array Values Modification
» NumPy String Functions
» NumPy Mathematical Functions
o Trigonometric Functions
o Rounding Functions
» NumPy Statistical functions
o Finding the Min and Max Elements from the Array
o Calculating Median, Mean, and Average of Array Items
NumPy Sorting and Searching
NumPy Copies and Views
NumPy Matrix Library
NumPy Linear Algebra
NumPy Matrix Multiplication in Python

YV VVYVY

DATA ANALYSIS WITH PYTHON PANDAS
» Pandas Introduction & Pandas Environment Setup
o Key Features of Pandas
o Benefits of Pandas
o Python Pandas Data Structure

= Series
= DataFrame
= Panel

» Pandas Series
o Creating a Series

= Create an Empty Series

= Create a Series using Inputs
Accessing Data from Series with Position
Series Object Attributes
Retrieving Index Array and Data Array of a Series Object
Retrieving Types (dtype) and Size of Type (itemsize)
Retrieving Shape
Retrieving Dimension, Size and Number of Bytes

o O O 0o O O
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o Checking Emptiness and Presence of NaNs

o Series Functions
> Pandas DataFrame
o Create a DataFrame
= Create an Empty DataFrame

= Create a DataFrame using Inputs

Column Selection, Addition & Deletion
Row Selection, Addition & Deletion
DataFrame Functions
Merging, Joining & Combining DataFrames
Pandas Concatenation
Pandas Time Series

o Datetime

o Time Offset

o Time Periods

o Convert String to Date
Viewing/Inspecting Data (loc & iloc)
Data Cleaning
Filter, Sort, and Groupby
Statistics on DataFrame
Pandas Vs NumPy
DataFrame Plotting

o Line: Line Plot (Default)
Bar: Vertical Bar Plot
Barh: Horizontal Bar Plot
Hist: Histogram Plot
Box: Box Plot
Pie: Pie Chart
Scatter: Scatter Plot

VVVYVYVYVYVYVY

YVVVVYVYVYY

0 O O 0O O O

DBMS - Structured Query Language
Introduction & Models of DBMS
SQL & Sub Language of SQL

Data Definition Language (DDL)
Data Manipulation Language (DML)

Transaction Control Language (TCL)
Data Control Language (DCL)

Sub Queries & Key Constraints
Aggregative Functions, Clauses & Views

VVVVVYVYYVYYYVYY

Importing & Exporting Data
» Data Extraction from CSV (pd.read_csv)

Data Query/Retrieval Language (DQL/DRL)

Installation of MySQL & Database Normalization

» Data Extraction from TEXT File (pd.read_table)
» Data Extraction from CLIPBOARD (pd.read_clipboard)

FlatNo.301, ANNAPURNA BLOCK, ADITYA ENCLAVE, AMEERPET, HYD

Ph:+91 7671043906, info@apectraining.com

www.apectraining.com


mailto:info@apectraining.com
http://www.apectraining.com/

VVVVY

AP EIC

transforming careers...

Data Extraction from EXCEL (pd.read_excel)
Data Extraction from URL (pd.read_html)
Writing into CSV (df.to_csv)
Writing into EXCEL (df.to_excel)
Data Extraction from DATABASES

o Python MySQL Database Connection

» Import mysql.connector Module

Create the Connection Object
Create the Cursor Object
Execute the Query

DATA VISUALIZATION WITH PYTHON MATPLOTLIB

VVVVVVVVVVVVVVYVYVVVVVVVVYYY

Data Visualization Introduction
Tasks of Data Visualization
Benefit of Data Visualization
Plots for Data Visualization
Matplotlib Architecture
General Concept of Matplotlib
MatPlotLib Environment Setup
Verify the MatPlotLib Installation
Working with PyPlot
Formatting the Style of the Plot
Plotting with Categorical Variables
Multi-Plots with Subplot Function
Line Graph
Bar Graph
Histogram
Scatter Plot
Pie Plot
3Dimensional - 3D Graph Plot
mpl_toolkits
Functions of MatPlotLib
Contour Plot, Quiver Plot, Violin Plot
3D Contour Plot
3D Wireframe Plot
3D Surface Plot
Box Plot

o What is a Boxplot?
Mean, Median, Quartiles, Outliers
Inter Quartile Range (IQR), Whiskers
Data Distribution Analysis
Boxplot on a Normal Distribution
Probability Density Function
68-95-99.7 Rule (Empirical rule)

O O 0O O O O

Data Analysis Project using Python Programming
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MACHINE LEARNING

What is Machine Learning
Importance of Machine Learning
Need for Machine Learning
Statistics Vs Machine Learning
Traditional Programming Vs Machine Learning
How Machine Learning like Human Learning
How does Machine Learning Work?
Machine Learning Engineer Responsibilities
Life Cycle of Machine Learning
Gathering Data
Data preparation
Data Wrangling
Analyze Data
Train the model
Test the model
o Deployment
Features of Machine Learning
History of Machine Learning
Applications of Machine Learning
Types of Machine Learning
o Supervised Machine Learning
o Unsupervised Machine Learning
o Reinforcement Learning

0O O O O O O

Supervised Machine Learning

>
>
>

>
>

How Supervised Learning Works?
Steps Involved in Supervised Learning
Types of supervised Machine Learning Algorithms
o Classification
o Regression
Advantages of Supervised Learning
Disadvantages of Supervised Learning

Unsupervised Machine Learning

>
>
>

YVVVY
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o What is a Dataset?
o Types of Data in Datasets
o Popular Sources for Machine Learning Datasets

Data Preprocessing in Machine Learning
» Why do we need Data Preprocessing?

o Getting the Dataset

o Importing Libraries

o Importing Datasets

o Finding Missing Data
= By Deleting the Particular Row
= By Calculating the Mean

o Encoding Categorical Data
» LableEncoder
= OneHotEncoder

o Splitting Dataset into Training and Test Set

o Feature Scaling
» Standardization
= Normalization

Classification Algorithms in Machine Learning
» What is the Classification Algorithm?
» Types of Classifications
o Binary Classifier
o Multi-class Classifier
» Learners in Classification Problems
o Lazy Learners
o Eager Learners
» Types of ML Classification Algorithms
o Linear Models
= Logistic Regression
» Support Vector Machines
o Non-linear Models
= K-Nearest Neighbors
= Naive Bayes
» Decision Tree Classification
= Random Forest Classification
= Kernel SVM
» Evaluating a Classification Model
o Confusion Matrix
= What is a Confusion Matrix?
e True Positive
e True Negative
e False Positive — Type 1 Error
e False Negative - Type 2 Error
= Why need a Confusion matrix?
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= Precision
= Recall
= Precision vs Recall
= F1-score
= Confusion Matrix in Scikit-Learn
= Confusion Matrix for Multi-Class Classification
o Log Loss or Cross-Entropy Loss
o AUC-ROC curve
» Use cases of Classification Algorithms

K-Nearest Neighbor(KNN) Algorithm in Machine Learning
» Why do we Need a K-NN Algorithm?
» How does K-NN work?
o What is Euclidean Distance
o How it Calculates the Distance
How to Select the Value of K in the K-NN Algorithm?
Advantages of KNN Algorithm
Disadvantages of KNN Algorithm
Python Implementation of the KNN Algorithm
Analysis on Social Network Ads Dataset
Steps to Implement the K-NN Algorithm
o Data Pre-processing Step
Fitting the K-NN algorithm to the Training Set
Predicting the Test Result
Test Accuracy of the Result (Creation of Confusion Matrix)
Visualizing the Test Set Result.
Improve the Performance of the K-NN Model

YVVVVYVYY

O O O O O

Naive Bayes Classifier Algorithm in Machine Learning
» Why is it Called Naive Bayes?
o Naive Means?
o Bayes Means?
> Bayes' Theorem
o Posterior Probability
o Likelihood Probability
o Prior Probability
o Marginal Probability
Working of Naive Bayes' Classifier
Advantages of Naive Bayes Classifier
Disadvantages of Naive Bayes Classifier
Applications of Naive Bayes Classifier
Types of Naive Bayes Model
o Gaussian Naive Bayes Classifier
o Multinomial Naive Bayes Classifier
o Bernoulli Naive Bayes Classifier
» Python Implementation of the Naive Bayes Algorithm

YV VVYVYY
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» Steps to Implement the Naive Bayes Algorithm
o Data Pre-processing Step
Fitting Naive Bayes to the Training set
Predicting the Test Result
Test Accuracy of the Result (Creation of Confusion matrix)
Visualizing the Test Set Result
Improve the Performance of the Naive Bayes Model

O O O O O

Decision Tree Classification Algorithm in Machine Learning
» Why use Decision Trees?
» Types of Decision Trees
o Categorical Variable Decision Tree
o Continuous Variable Decision Tree
Decision Tree Terminologies
How does the Decision Tree Algorithm Work?
Attribute Selection Measures
o Entropy
o Information Gain
o Gini index
o Gain Ratio
» Algorithms used in Decision Trees
o ID3 Algorithm — (Extension of D3)
o C4.5 Algorithm— (Successor of ID3)
o CART Algorithm — (Classification & Regression Tree)
» How to Avoid/Counter Overfitting in Decision Trees?
o Pruning Decision Trees
o Random Forest
Pruning: Getting an Optimal Decision tree
Advantages of the Decision Tree
Disadvantages of the Decision Tree
Python Implementation of Decision Tree
Steps to Implement the Decision Tree Algorithm
o Data Pre-processing Step
Fitting a Decision-Tree Algorithm to the Training Set
Predicting the Test Result
Test Accuracy of the Result (Creation of Confusion matrix)
Visualizing the Test Set Result
Improve the Performance of the Decision Tree Model

Y V V

YV VVYVY

o O O O O

Random Forest Classifier Algorithm in Machine Learning
» Working of the Random Forest Algorithm
» Assumptions for Random Forest
» Why use Random Forest?
» How does Random Forest Algorithm Work?
o Ensemble Techniques
o Bagging (Bootstrap Aggregation)
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> Applications of Random Forest

» Disadvantages of Random Forest

» Python Implementation of Random Forest Algorithm
> Steps to Implement the Random Forest Algorithm:

©)

O O O O O

Data Pre-processing Step

Fitting the Random Forest Algorithm to the Training Set
Predicting the Test Result

Test Accuracy of the Result (Creation of Confusion Matrix)
Visualizing the Test Set Result

Improving the Performance of the Random Forest Model

Logistic Regression Algorithm in Machine Learning
» Logistic Function (Sigmoid Function)
» Assumptions for Logistic Regression
» Logistic Regression Equation
» Type of Logistic Regression

@)
®)
®)

Binomial Logistic Regression
Multinomial Logistic Regression
Ordinal Logistic Regression

» Python Implementation of Logistic Regression (Binomial)
» Steps to Implement the Logistic Regression:

(@]

O O O O O

Data Pre-processing Step

Fitting Logistic Regression to the Training Set

Predicting the Test Result

Test Accuracy of the Result (Creation of Confusion Matrix)
Visualizing the Test Set Result

Improve the Performance of the Logistic Regression Model

Support Vector Machine Algorithm
> Types of Support Vector Machines

@)
©)

Y V V

©)
@)

Linear Support Vector Machine
Non-Linear Support Vector Machine

Hyperplane in the SVM Algorithm
Support Vectors in the SVM Algorithm
How does SVM Works?

How does Linear SVM Works?
How does Non-Linear SVM Works?

» Python Implementation of Support Vector Machine
> Steps to Implement the Support Vector Machine:

o

0 O O O O

Data Pre-processing Step

Fitting Support Vector Machine to the Training Set

Predicting the Test Result

Test Accuracy of the Result (Creation of Confusion Matrix)
Visualizing the Test Set Result

Improve the Performance of the Support Vector Machine Model
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Regression Algorithms in Machine Learning
» Terminologies Related to the Regression Analysis
Dependent Variable
Independent Variable
Outliers
Multi-collinearity
o Under fitting and Overfitting
» Why do we use Regression Analysis?
> Types of Regression
Linear Regression
Logistic Regression
Polynomial Regression
Support Vector Regression
Decision Tree Regression
Random Forest Regression
Ridge Regression
Lasso Regression

©)
@)
©)
©)

O O O 0O O O O O

Linear Regression in Machine Learning
» Types of Linear Regression
o Simple Linear Regression
o Multiple Linear Regression
» Linear Regression Line
o Positive Linear Relationship
o Negative Linear Relationship
» Finding the Best Fit Line
o Cost Function
o Gradient Descent
o Model Performance
o R-Squared Method
» Assumptions of Linear Regression

Simple Linear Regression in Machine Learning
» SLR Model
» Implementation of Simple Linear Regression Algorithm using Python
o Data Pre-processing Step
Fitting Simple Linear Regression to the Training Set
Predicting the Test Result
Test Accuracy of the
Visualizing the Test Set Result.
Try to Improve the Performance of the Model

0 O O O O

Multiple Linear Regression in Machine Learning
» MLR Equation
» Assumptions for Multiple Linear Regression
» Implementation of Multiple Linear Regression model using Python
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Data Pre-processing Step

Fitting Multiple Linear Regression to the Training Set
Predicting the Test Result

Test Accuracy of the

Visualizing the Test Set Result.

Try to Improve the Performance of the Model

Backward Elimination
» What is Backward Elimination?
» Steps of Backward Elimination
> Need for Backward Elimination: An optimal Multiple Linear Regression

model

» Implement the Steps for Backward Elimination method

Polynomial Regression in Machine Learning

Need for Polynomial Regression

Equation of the Polynomial Regression Model
Implementation of Polynomial Regression using Python
Steps for Polynomial Regression:

>

Y V V

VVVVYVYVYVYY
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o

Data Pre-processing

Build a Linear Regression Model

Build a Polynomial Regression Model

Visualize the Result for Linear Regression Model

Visualize the Result for Polynomial Regression Model

Predicting the Final Result with the Linear Regression Model
Predicting the Final Result with the Polynomial Regression Model

Support Vector Regression (SVR)
Decision Tree Regression

Random Forest Regression

Ridge Regression

Lasso Regression

Linear Regression Vs Logistic Regression
Classification vs Regression

Clustering Algorithms in Machine Learning
» Types of Clustering Methods

©)
@)
©)
©)

o

Partitioning Clustering
Density-Based Clustering
Distribution Model-Based Clustering
Hierarchical Clustering

Fuzzy Clustering

» Clustering Algorithms

o

@)
@)
@)

K-Means Algorithm

Mean-shift Algorithm

DBSCAN Algorithm

Expectation-Maximization Clustering using GMM
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o Agglomerative Hierarchical Algorithm
o Affinity Propagation
» Applications of Clustering

Hierarchical Clustering Algorithm in Machine Learning
Hierarchical Clustering Technique Approaches
Why Hierarchical Clustering?
Agglomerative Hierarchical Clustering
How the Agglomerative Hierarchical Clustering Work?
Measure for the Distance between two Clusters
o Single Linkage
o Complete Linkage
o Average Linkage
o Centroid Linkage
Working of Dendrogram in Hierarchical Clustering
Hierarchical Clustering Example with Scratch Data
Python Implementation of Agglomerative Hierarchical Clustering
Steps for Implementation of Agglomerative Hierarchical Clustering
using Python
o Data Pre-processing
o Finding the Optimal Number of Clusters using the Dendrogram
o Training the Hierarchical Clustering Model
o Visualizing the Clusters

VVVYY

YV VY

K-Means Clustering Algorithm in Machine Learning

» What is K-Means Algorithm?

» How does the K-Means Algorithm Work?

» How to Choose the Value of "K Number of Clusters" in K-Means
Clustering?

o Elbow Method

o Within Cluster Sum of Squares (WCSS)
K-Means Clustering Example with Scratch Data
Python Implementation of K-means Clustering Algorithm
Steps to Implement of K-means Clustering Algorithm

o Data Pre-processing
Finding the Optimal Number of Clusters using the Elbow Method
Training the K-means Algorithm on the Training Dataset
Visualizing the Clusters

Y V V

o O O

Association Rules in Machine Learning
Association Rules

Pattern Detection

Market Basket Analysis

Support, Confidence, Expected Confidence, Lift
Finding Item Sets with High Support

Finding Item Rules with High Confidence or Lift

VVVYVYVYY
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Apriori Algorithm in Machine Learning

Apriori Algorithm

How does Apriori Algorithm Works?

Apriori Algorithm Example

Implementation of Apriori Algorithm using Python
Limitations of Apriori Algorithm

YV VVYYVY

Dimensionality Reduction & Model Selection Boosting
» Dimensionality Reduction
o Principal Component Analysis (PCA)
o Linear Discriminant Analysis (LDA)
o Kernel PCA
» Model Selection Boosting
o Model Selection
» Grid Search & K-Fold Cross Validation

o XGBoost
STATISTICS
» Mean, Median and Mode
» Data Variability, Range, Quartiles
> IQR, Calculating Percentiles
» Variance, Standard Deviation, Statistical Summaries
» Types of Distributions — Normal, Binomial, Poisson
> Probability Distributions & Skewness
» Data Distribution, 68-95-99.7 rule (Empirical rule)
» Descriptive Statistics and Inferential Statistics
» Statistics Terms and Definitions, Types of Data
> Data Measurement Scales, Normalization, Standardization
» Measure of Distance, Euclidean Distance
> Probability Calculation - Independent & Dependent
» Entropy, Information Gain
» Regression

NATURAL LANGUAGE PROCESSING

> Natural Language Processing Introduction
o What is NLP?
o History of NLP
o Advantages of NLP
o Disadvantages of NLP

» Components of NLP
o Natural Language Understanding (NLU)
o Natural Language Generation (NLG)
o Difference between NLU and NLG

> Applications of NLP

» How to build an NLP Pipeline?
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» Phases of NLP

@)
@)
@)
©)

©)

YV VYV

Lexical Analysis and Morphological
Syntactic Analysis (Parsing)
Semantic Analysis

Discourse Integration

Pragmatic Analysis

Why NLP is Difficult?

NLP APIs

NLP Libraries

Natural Language Vs Computer Language

Exploring Features of NLTK

o

O 0 O O O O O O O

o

Open the Text File for Processing
Import Required Libraries
Sentence Tokenizing

Word Tokenizing

Find the Frequency Distribution
Plot the Frequency Graph
Remove Punctuation Marks
Plotting Graph without Punctuation Marks
List of Stopwords

Removing Stopwords

Final Frequency Distribution

> Word Cloud

o

©)
@)
©)
©)

Word Cloud Properties

Python Code Implementation of the Word Cloud
Word Cloud with the Circle Shape

Word Cloud Advantages

Word Cloud Disadvantages

» Stemming

©)
©)

Stemmer Examples
Stemming Algorithms
Porter’s Stemmer
Lovin’s Stemmer
Dawson’s Stemmer
Krovetz Stemmer
Xerox Stemmer

= Snowball Stemmer

> Lemmatization

©)
@)
@)
©)

o

Difference between Stemmer and Lemmatizer
Demonstrating how a lemmatizer works
Lemmatizer with default PoS value
Demonstrating the power of lemmatizer
Lemmatizer with different POS values

» Part-of-Speech (PoS) Tagging

o
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o Part of Speech (PoS) Tags
» Chunking
o Categories of Phrases
o Phrase Structure Rules
» Chinking
» Named Entity Recognition (NER)
o Use-Cases
o Commonly used Types of Named Entity
» WordNet
> Bag of Words
o What is the Bag-of-Words method?
Creating a basic Structure on Sentences
Words with Frequencies
Combining all the Words
Final Model of our Bag of Words
o Applications & Limitations
> TF-IDF
o Term Frequency
o Inverse Document Frequency
o Term Frequency - Inverse Document Frequency

@)
®)
®)
®)

Deploying a Machine Learning Model on a Web using Flask
What is Model Deployment?

What is Flask?

Installing Flask on your Machine

Understanding the Problem Statement

Build our Machine Learning Model

Create the Webpage

Connect the Webpage with the Model

Working of the Deployed Model

VVVVVVYVYY

DEEP LEARNING INTRODUCTION

» What is Deep Learning?

> Deep learning Process

» Types of Deep Learning Networks
o Deep Neural Networks
o Artificial Neural Networks
o Convolutional Neural Networks
o Recurrent Neural Networks

> TensorFlow
o History of TensorFlow
o Components of TensorFlow
o Use Cases/Applications of TensorFlow
o Features of TensorFlow

» Installation of TensorFlow through pip & conda
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» Advantage and Disadvantage of TensorFlow
» TensorFlow Playground

» Introduction to Keras, OpenCV & Theano

» Implementation of Deep Learning

ARTIFICIAL INTELLIGENCE INTRODUCTION
» What is Artificial Intelligence?
o Why Artificial Intelligence?
o Goals of Artificial Intelligence
o What Comprises to Artificial Intelligence?
o Advantages of Artificial Intelligence
o Disadvantages of Artificial Intelligence
Applications of Artificial Intelligence
History of Artificial Intelligence
Types of Artificial Intelligence
Types of Al Agents
o Simple Reflex Agent
o Model-Based Reflex Agent
o Goal-Based Agents
©)
©)

YV VYV

Utility-Based Agent
Learning Agent
» Search Algorithms in Artificial Intelligence
o Search Algorithm Terminologies
o Properties of Search Algorithms
o Types of Search Algorithms
» Subsets of Artificial Intelligence
» Implementation of Artificial Intelligence

R PROGRAMMING

Why R Programming is Important?

Why Learn R?

History of Python

Features of R

Applications of R

Comparison between R and Python

Which is Better to Choose

Pros and Cons of R

Companies using R

R Packages

Downloading and Installing R

What is CRAN?

Setting R Environment:
o Search Packages in R Environment
o Search Packages in Machine with inbuilt function and manual

searching

VVVVVVYVYVYVYVVVYY
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Attach Packages to R Environment
Install Add-on Packages from CRAN
Detach Packages from R Environment
o Functions and Packages Help
» R Programming IDE
o RStudio
o Downloading and Installing RStudio
» Variable Assignment
o Displaying Variables
o Deleting Variables
» Comments
o Single Line
o Multi Line Comments
» Data Types
o Logical
o Integer
o Double
o Complex
o Character
» Operators
o Arithmetic, Relational, Logical, Assignment Operators
o R as Calculator
o Performing different Calculations
» Functions
o Inbuilt Functions
o User Defined Functions
» STRUCTURES
o Vector
List
Matrix
Data frame
Array
o Factors
» Inbuilt Constants & Functions
> Vectors
o Vector Creation
Single Element Vector
Multiple Element Vector
Vector Manipulation
Sub setting & Accessing the Data in Vector

O O O

©)
@)
@)
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o O O O
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Creating a List

Naming List Elements
Accessing List Elements
Manipulating List Elements

o O O O
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o Merging Lists

o Converting List to Vector
» Matrix

o Creating a Matrix

o Accessing Elements of a Matrix

o Matrix Manipulations

o Dimensions & Transpose of Matrix
» Data Frames

o Create Data Frame
Vector to Data Frame
Character Data Converting into Factors: StringsAsFactors
Convert the columns of a data frame to characters
Extract Data from Data Frame

o Expand Data Frame, Column Bind and Row Bind
» Merging / Joining Data Frames

o Inner, Outer & Cross Join
» Arrays

o Create Array with Multiple Dimensions

o Naming Columns and Rows

o Accessing Array Elements

o Manipulating Array Elements

o Calculations across Array Elements
» Factors

o Factors in Data Frame

o Changing the Order of Levels

o Generating & Deleting Factor Levels

O O O O

Loading and Reading Data in R
» Data Extraction from CSV
o Getting and Setting the Working Directory
o Input as CSV File, Reading a CSV File
o Analyzing the CSV File, Writing into a CSV File
» Data Extraction from URL
» Data Extraction from CLIPBOARD
» Data Extraction from EXCEL
o Install “xIsx” Package
o Verify and Load the "xIsx" Package, Input as “xlIsx” File
o Reading the Excel File, Writing the Excel File
» Data Extraction from DATABASES
o RMySQL Package, Connecting to MySq|
Querying the Tables, Query with Filter Clause
Updating Rows in the Tables, Inserting Data into the Tables
Creating Tables in MySql, Dropping Tables in MySq|
Using dplyr and tidyr package

o O O O
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Machine Learning using R
» Data Pre-processing
» Classification Algorithms
o K Nearest Neighbors & Naive Bayes Classification
o Decision Tree & Random Forest Classification
o Support Vector Machine Classification
o Logistic Regression & Kernel SVM
» Regression Algorithms
o Simple & Multiple Linear Regression
o Polynomial & Support Vector Regression
o Decision Tree & Random Forest Regression
» Clustering Algorithms
o K-Means & Hierarchical Clustering
» Association Rule Algorithms
o Apriori & Eclat
» Dimensionality-Reduction
o Principal Component Analysis
o Linear Discriminant Analysis & Kernal PCA
» Model Selection & Boosting
o Grid Search, K Fold Cross Validation & XGBoost
» Natural Language Processing
» Deep Learning - Artificial Neural Networks

DATA MINING WEKA
» Explore Weka Machine Learning Toolkit
o Installation of WEKA, Features of WEKA Toolkit
o Explore & Load data sets in Weka
» Perform Data Preprocessing Tasks
o Apply Filters on Data Sets
» Performing Classification on Data Sets
o J48 Classification & Decision Trees Algorithm
o K-NN & Naive-Bayes Classification Algorithm
o Comparing Classification Results
» Performing Regression on Data Sets
o Simple, Multi Linear & Logistic Regression Model
o Cross-Validation and Percentage Split
» Performing Clustering on Data Sets
o Clustering Techniques in Weka
Simple K-means Clustering Algorithm
Association Rule Mining on Data Sets
Apriori Association Rule Algorithm
Discretization in the Rule Generation Process
» Graphical Visualization in Weka
o Visualization Features in Weka
o Visualize the data in various dimensions
o Plot Histogram, Derive Interesting Insights
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